WordPress webmasters urged to upgrade to version 4.73…

WordPress webmasters urged to upgrade to version 4.73 to patch six security holes

Another day, another important security update for WordPress. Oh boy.

If you administer your own self-hosted WordPress website then your must update the software as soon as possible, following the disclosure of six security holes that could be exploited by malicious attackers….. READ MORE!